Indexcoop won't connect with Meta Mask

I try to log in to my indexcoop wallet on Brave Browser. It won’t connect with my Meta Mask wallet.

What do you mean by “log in to my indexcoop wallet”?
You just login to your MetaMask wallet (to your ETH address).
Maybe you meant you do not see the Token Index. If so, then just import the Token Index (MetaMask - Assets, scroll down “Import Tokens”, if search token INDEX does not work, open another browser tab, go to Index Cooperative price, INDEX chart, market cap, and info | CoinGecko find the MetaMask icon and import the Token to your Metamask wallet.)

Good luck!

Hi! Welcome to the Coop!

This sounds like an issue that crops up with the Metmask Brave combo sometimes. There is a post on Metamask community with a fix - Brave and metamask dosent work - #15 by Buzz3210 - New to MetaMask? Start Here - MetaMask

When i click login, it takes me to “select wallet.” I select Metamask and nothing happens. Other wallets respond, but I need to connect Metamask.

Brave is a Chrome clone. Did you install in Brave the MetaMask extension?

As @Elmit says, Brave is a Chrome clone, so extensions should work. However, Brave has wallets built in so, for the Metamask extension to work, you should turn off the wallets, then it shouldn’t ask - Metamask can hook-in like in Chrome.

1 Like

I can confirm that Brave + MetaMask + works fine for me. I just tested this and have not have any issue with this set up before.

I don’t think your issue is related to the indexcoop website. Other than the suggestions above perhaps also check both Brave and MetaMask for software updates.

Based on everything I’m reading, this to me seems the most likely reason. The built in Brave wallet is also just a rip of Metamask, so there’s certainly a conflict there.